Close

Service Interruption

Geolocating MODIS Climate Modeling Grid (CMG) Data in ENVI


This tutorial explains how to geolocate MOD10C1, MYD10C1, MOD10C2, and MYD10C2 data to a Geographic projection using ENVI software. These steps were tested with ENVI 4.0 on a Windows 2000 platform.



1. Start ENVI, click File → Open Image File, and select your MODIS CMG data file. In the HDF Dataset Selection window, select an HDF Dataset to view (usually the snow cover extent field). Click OK. In the Available Bands List window, click Load Band. ENVI reads and displays the file without asking for header information, but you will need to edit the header in the following steps.


2. From the main ENVI menu, click File → Edit ENVI Header. In the Edit Header Input File window, highlight the file name on the left and click OK.


3. In the Header Info window, click Edit Attributes and select Map Info. ENVI references the upper-left corner of the upper-left pixel of an image as (1,1). The corresponding geographic coordinates of the upper-left corner of the upper-left pixel of a MODIS CMG image are (-180.00, 90.00). In the Edit Map Information window, enter the following values:

Image Coord X and Y: 1.0
Pixel Size X and Y: 0.05


4. Click Change Proj.... In the Projection Selection window, highlight "Geographic Lat/Lon" and leave the Datum and Units as is. Click OK.


5. Click the Up/Down Arrow button and click DDEG. Enter the following values:

Lat: 90.0
Lon: -180.0

Click OK, then again in the Header Info window. ENVI creates a new header, and the image disappears.


6. In the Available Bands List window, a Map Info line appears below the file name. Click Load Band. The geolocated image appears. You can now overlay grid lines or select Tools → Cursor Location/Value to see coordinates of each pixel.