Close

Service Interruption

Geolocating and Regridding AMSR-E Level-3 Soil Moisture Data in ENVI

This document describes how to regrid "AMSR-E/Aqua Daily L3 Surface Soil Moisture, Interpretive Parms, & QC EASE-Grids" in HDF-EOS format. This data set is in a global cylindrical EASE-Grid with a nominal grid resolution of 25 km (true at 30° S). The size of the grid is 1383 columns (samples) by 586 rows (lines). These procedures were tested with ENVI 4.0 on a Windows 2000 platform; other versions of ENVI may have slightly different menu options and steps.


Obtain Latitude/Longitude Grids

1. Download the file Ml_geolocation.tar.gz to your computer. This tar file contains flat binary grids of 4-byte integers with latitudes and longitudes for each pixel in a cylindrical EASE-Grid. You will need to divide these values by 100,000 (see Step 4 below) to yield values in decimal degrees with 1 m precision. Unzip and untar the contents to extract four files:

MLLATLSB: Latitude grid, little-endian byte order
MLLATMSB: Latitude grid, big-endian byte order
MLLONLSB: Longitude grid, little-endian byte order
MLLONMSB: Longitude grid, big-endian byte order

Choose the correct two files, based on your system's byte order. These will be referred to as <latitude_file> and <longitude_file> in subsequent steps.


2. Start ENVI, click File --> Select Image File, and select <latitude_file>.


3. In the Header Info window, enter the following parameters:

Samples: 1383
Lines: 586
Bands: 1
Data Type: Long integer

Leave everything else as default. Click OK. The Available Bands List window appears. Leave this window open but drag it out of the way; you will not need to change anything for now.

Repeat this step with <longitude_file>.


4. From the main ENVI menu, click Basic Tools --> Band Math. In the Band Math window, enter ".00001*float(b1)" in the Enter an expression field. Click OK.


5. In the Variables to Bands Pairings window, select "Band 1" under <latitude_file>. In the Enter Output Filename field, type an output file name (for example, "mllatlsb_scaled"). Click OK.


6. Repeat Steps 3-4 for the <longitude_file> using an output file name of "mllonlsb_scaled."


Build a Geographic Lookup Table (GLT)

ENVI first requires a GLT to georeference the AMSR-E Level-3 data. You will create a GLT in these steps.


1. From the main ENVI menu, click Map --> Georeference from Input Geometry --> Build GLT.


2. In the Input X Geometry Band window, highlight your scaled longitude grid (for example, "mllonlsb_scaled") and click OK.


3. In the Input Y Geometry Band window, highlight your scaled latitude grid (for example, "mllatlsb_scaled") and click OK.


4. In the Geometry Projection Information window, highlight Geographic Lat/Lon in the "Input Projection of Geometry Bands" and select "WGS-84" for Datum and "Degrees" for Units. In the "Output Projection for Georeferencing" section, enter an output projection, datum, and units of your choice. Click OK.


5. In the Build Geometry Lookup File Parameters window, change Output rotation to 0°. Leave everything else as default, but provide an output file name (for example, "glt"). Click OK. The Available Bands List window refreshes.


Use the GLT to Geolocate Data

1. From the main ENVI menu, click File --> Open Image File. Select an AMSR-E Level-3 soil moisture file (.hdf) on your computer.


2. From the HDF Dataset Selection window, select the HDF-EOS field(s) you want to geolocate. Use the <Ctrl> key to select multiple, nonadjacent datasets. Click OK. The Available Bands List window appears, displaying the selected fields.


3. From the main ENVI menu, click Map --> Georeference from Input Geometry --> Georeference from GLT.


4. In the Input Geometry Lookup File window, select the GLT you just created in Step 5 earlier ("glt"). Click OK.


5. In the Input Data File window, select an AMSR-E field name. Note the multiple instances of the same file name; these are the different fields you selected in Step 2 above. So when you highlight a field name in this window, you will create a new grid that combines latitude and longitude values with your specified field. Click OK.


6. Enter an output file name.


7. In the Available Bands List window, select the new file you created and click Load Band. The AMSR-E data file displays, and you can confirm the latitude and longitude of each pixel by selecting Tools -->Cursor Location/Value from the display window.